eXe&Tiny Plugins
Usamos cookies para analizar nuestro tráfico y personalizar contenidos y anuncios. También compartirmos información sobre el uso que haces de este sitio con nuestros anunciantes y socios de análisis. Al navegar por este sitio, aceptas la instalacion de cookies como se describe en Datos legales. Por tanto, si no quieres habilitar las cookies, pulsa el botón Cancelar y tu navegador te llevará a otro sitio. En otro caso, haz clic sobre el botón the Accepto, las cookies serán instalada en tu computador y podrás navegar por estas páginas.




eXe&Tiny Plugins Suite está disponible en dos versiones: una para eXeLearning 2.0 y otra para TinyMCE 4.3. Continúa leyendo la explicación de esta dualidad.

Dos pájaros de dos tiros

eXeLearning es uno de los más populares sistemas de autor gratuitos para la creación de contenido educativo en diferentes formatos digitales —SCORM, XHTML, HTML5 y otros— que pueden ser usados de forma independiente o integrados en un LMS, como Chamilo o Moodle. Trabaja en tu navegador favorito y de manera off-line, pero permite una vista previa del contenido web para comprobar cómo se verá el resultado cuando se publique en línea.

Como probablemente sepas, esta herramienta incluye TinyMCE 3.5.7, una librería JavaScript capaz de convertir un campo de área de texto en un poderoso editor HTML, cuya mayor ventaja es una arquitectura modular que proporciona una extensa API para su integración, con la que cualquiera en cualquier parte puede extender su funcionalidad a través de plugins instalables. Cuando tuvimos que afrontar la necesidad de desarrollar extensiones para eXeLearning, aprovechamos esta circunstancia. De hecho, todo lo que tuvimos que hacer fue escribir componentes para TinyMCE 3.5.7, la versión de esta librería incorporada en la aplicación eXeLearning 2.0.

Ahora, las malas noticias. La mayoría de los programas web —especialmente los CMS como WordPress, Joomla o Drupal— usa la última versión estable de TinyMCE, la 4.x, en vez de la antigua 3.5.7. Este nuevo lanzamiento tiene una API actualizada con muchos cambios: una estructura de archivos diferente, otra manera de manejar los eventos, una interfaz de usuario mejorada, etc. En definitiva, esto significa que los plugins escritos para TinyMCE 3.5.7 y eXeLearning 2.0 no funcionan en TinyMCE 4.3, así como tampoco en los antes mencionados CMS.

Afortunadamente, parte del personal de APLICACIONEZ® es gente que se dedica al desarrollo, convencida de que no hay problema en este mundo tan serio que no pueda ser resuelto con unas pocas líneas de código, una impresionante colección de camisetas y muchas tazas de café. Como resultado, hoy podemos poner a tu disposición dos versiones de la suite eXe&Tiny Plugins, una diseñada para su instalación en eXeLearning 2.0 y otra que puede ser añadida a cualquier sitio web donde normalmente se ejecute TinyMCE 4.3, incluyendo aquellos sitios gestionados por los más usados CMS.

También hay dos tipos de descarga independientes para cada uno de los plugins, de modo que puedas elegir entre instalar la suite completa o solo el componente o los componentes que pienses utilizar.


Componentes